Meine Werkzeuge
User menu

Andere PHP Versionen

Aus Domain-Offensive - Wiki

Wechseln zu: Navigation, Suche

Auf unseren Webservern ist es möglich, eine andere PHP-Version einzusetzen.

Aktuell gibt es zwei verschiedenen Möglichkeiten die PHP-Version zu ändern, entweder über die PHP-Einstellungen oder manuell per .htaccess Datei.

PHP-Version über PHP-Einstellungen ändern

Kundenmenue webspace.png

Navigieren Sie bitte zum Punkt "Webspace".
PHP-Einstellungen.png

Klicken Sie bei dem betreffenden Webspace auf den Button "Details".
441px-PHP-version-aendern.PNG

Unter dem Punkt PHP-Einstellungen haben Sie die Möglichkeit Änderungen an den Grundeinstellungen Ihres Webspace vorzunehmen. Bitte beachten Sie eine Änderung bis zu 15min Übernahmezeit benötigen kann.

Wichtig: Veränderungen an den PHP Einstellungen, die von den Grundeinstellungen abweichen, können die Funktionalität der Internetseiten und Projekten negativ beeinflussen. Wir empfehlen Ihnen nur mit entsprechenden Kenntnissen die Einstellungen vorzunehmen.

verschiedene PHP-Version nutzen

Möchten Sie verschiedene PHP-Versionen gleichzeitig benutzen funktioniert das über HTACCESS. Dazu kann im Hauptordner der Webseite eine .htaccess Datei angelegt werden. In dieser kann dann die PHP-Version vorgegeben werden welche verwendet werden soll.

Standard-PHP-Version

AddHandler x-httpd-php5 .php

PHP 5.3

AddHandler x-httpd-php53 .php

Wichtig: Bei PHP-Versionen über 5.3 gibt es die Konfiguration "safe_mode" nicht mehr. Diese muss über die Webspace-Einstellungen auf der Domain-Offensive deaktiviert werden.

PHP 5.4

AddHandler x-httpd-php54 .php

PHP 5.5

AddHandler x-httpd-php55 .php

PHP 5.6

AddHandler x-httpd-php56 .php